Vous avez un site Joomla 1.5 en production, pourquoi faut-il migrer ?

Joomla 1.5 vs Joomla 3.3Vous avez encore un site Joomla 1.5 en service, vous lisez ici ou là qu'il vous faut passer à la version 3 de Joomla et vous souhaitez comprendre les raisons d'une migration devenue indispensable ?

Mises à jour de sécurité

Depuis septembre 2012, la version 1.5 de Joomla n'est plus "supportée" par la communauté. Cela signifie qu'il n'y aura plus de mises à jour de sécurité publiée pour les failles du système qui sont utilisées par les pirates pour rendre votre site indisponible ou diffuser leurs contenus... Votre site est donc devenu plus vulnérable.

Version de PHP

Le langage de programmation (PHP version 5.2) qui permet à un site Joomla 1.5 de fonctionner est obsolète. Ce qui induit de nouvelles causes probables de vulnérabilité. Aujourd'hui la version de PHP utilisée est la 5.4. Malheureusement, les sites Joomla 1.5 risquent fortement de ne plus fonctionner avec cette version.

Extensions

Tout comme le coeur de Joomla, les extensions externes ne sont plus maintenues, cela accroit le risque d'intrusion pour les sites qui en utilisent.

Graphisme (template)

Le graphisme des sites Joomla a énormément évolué depuis la version 1.5, ce qui permet d'avoir des template plus stables, compatibles avec la majorité des navigateurs modernes et surtout "responsiv design" (qui s'adaptent en fonction du terminal de consultation).

Facilité des mises à jour

Les versions récentes de Joomla facilitent la mise à jour du coeur de Joomla mais également des extensions tiers, ce qui ne peut qu'accroitre la fiabilité et la sécurité de votre site.

Nouvelles fonctionnalités

De nouvelles fonctionnalités sont disponibles avec les versions plus récentes, les extensions sont maintenant développées pour ces versions et facilitent l'intéraction avec les visiteurs (web 2.0 et 3.0).

Garder une technologie actuelle et évolutive

Joomla utilise un langage de programmation et une base de données qui évoluent très régulièrement avec le web, les besoins de performances et d'adaptabilité pour les tablettes, mobiles et autres terminaux. Il est essentiel de maintenir à niveau l'ensemble afin de ne pas être rattrapé par une obsolescence qui empêcherait tôt ou tard le site de rattraper son retard. Les hébergements actuels sont de moins en moins tolérants envers ces vieilles technologies, il devient difficile de les maintenir en ligne.

Conclusion

Il y a beaucoup de différences entre un Joomla 1.5.x et un Joomla 3.3.x qui rendent la transition entre ces versions très délicate mais encore possible. Pour assurer la stabilité et la sécurité de votre site, cette migration est devenue indispensable. Selon la complexité de votre site, elle pourra se faire rapidement et simplement ou demandera un traitement particulier plus long. Dans tous les cas le graphisme est à reprendre, c'est peut être une bonne occasion pour donner un petit coup de jeune à votre site ?

Autant faire de cette étape indispensable un atout et en profiter pour relancer votre site dans son époque avec un look modernisé et adaptable sur tout écran !